Pandora Mail Forum
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Go down
avatar
urbite
Posts : 18
Join date : 2021-09-13

Spacing changed when pasting into new email Empty Spacing changed when pasting into new email

Wed Dec 08, 2021 10:45 pm
If I paste text from an editor into a new email, any run of consecutive spaces is replaced by a single space. The use case is as follows:

  1. Creating  a simple table in an editor, such as Notepad++
  2. Copy table
  3. Paste into Pandora email
  4. All runs of spaces in original text are replaced by single spaces

For example,
Code:
'Hello    how are u':  Text copied from Notepad++
'Hello how are u': Text after pasting into new Pandora email:  
The intent was to change the formatting to TW (monospaced) after pasting, so that the table will match what was in the original editor. The reason for creating a table in another editor is the much more powerful editing features.

I'm composing the email in HTML mode, as I'd like to have mixed formatting. As I was composing this topic, I noticed that when posting the above example without the 'code' formatting option, the extra spaces were also eaten in this post. So maybe there's some kind of limitation of consecutive spaces with HTML?

Am I correct in that HTML mode is only formatting option, other than plain text. Is the HTML formatter eating the extra spaces? I checked the settings for Composing Mail and didn't see any obvious setting.
JeremyNicoll
JeremyNicoll
Posts : 8
Join date : 2020-09-05
Location : Edinburgh, Scotland

Spacing changed when pasting into new email Empty Re: Spacing changed when pasting into new email

Thu Dec 09, 2021 5:05 pm
HTML doesn't pay any attention to spaces (on a webpage) and lays out the text according to its own rules (and CSS etc).

If - on a webpage - and presumably also in HTML-formatted email - a page designer wants literal spaces to be placed between items of text (which nowadays would be more likely to be done with CSS) then they need to tell the HTML layout engine to do that by representing each required space by something that names a character which is known as a "non=breaking space".

In HTML this is 6 characters long - an ampersand, the letters "nbsp" and then a semicolon.   I'm not sure if I type that here that it will actually be visible as those characters rather than being translated to a space.  But let's try, to represent "A" then three spaces then "B":

A   B

Presumably you'll need to do the same in your editor.
avatar
urbite
Posts : 18
Join date : 2021-09-13

Spacing changed when pasting into new email Empty Re: Spacing changed when pasting into new email

Wed Jan 05, 2022 3:48 pm
As I understand it, the only two formats available when composing and email in Pandora are plain text and html. Is this correct?

If html is the only non-plain text option, does this mean that to compose an email with non-plain formatting that has consecutive spaces, one has to insert html to make it appear as desired?
JeremyNicoll
JeremyNicoll
Posts : 8
Join date : 2020-09-05
Location : Edinburgh, Scotland

Spacing changed when pasting into new email Empty Re: Spacing changed when pasting into new email

Wed Jan 05, 2022 6:12 pm
I suppose that something else that might work is to enclose what you paste in, in <code> .... </code> tags.

Interestingly I just tried to enclose that example here (on the forum) using the 'Code' button above, and it didn't work.

An additional problem whatever you do is that not all email clients (so this affects the people you send your emails to) enable html viewing at all, and of those that do, some are more restricted than others.
Sponsored content

Spacing changed when pasting into new email Empty Re: Spacing changed when pasting into new email

Back to top
Permissions in this forum:
You cannot reply to topics in this forum