Pandora Mail Forum
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Go down
avatar
Simoncu
Posts : 13
Join date : 2019-05-15

cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG Empty cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG

on Tue Mar 24, 2020 9:56 am
That's right, when I type an address, and I want to put the "@" in it, Which , on my swiss french keyboard is AltGr + 2, all that happens is that the junk mailbox opens. Normally the shortcut.is Ctrl+2, which works as well, but it's VERY annoying no being able to type the @ in an address :-) Is there some ini filethat can be edited with these shortcuts ?
Ok, I can use the ASCII code ( ALT + 064) but that's not a good solution.

Many thanks

Simon
Admin
Admin
Admin
Posts : 182
Join date : 2018-06-02
http://www.drivehq.com/web/brana/pandora.htm

cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG Empty Re: cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG

on Tue Mar 24, 2020 4:24 pm
Simon, when you add US English keyboard layout via:
Control Panel/Region and Language/Keyboards and Languages/Change Keyboards/Add > English (US) > OK
Make your current Swiss-French keyboard as default.
Assign keyboard shortcut switch via Advanced Key Settings tab, say Left Alt + Shift. Left Alt + Shift is assigned automatically on Windows 7.
Close all settings dialogs with OK, notice the Language indicator on Windows taskbar.

Now, start Pandora, compose new message, click on To field, and switch the keyboard to English (US). Type @ and test other characters.
Hit F6 or click on body text, switch to Swiss keyboard, and type accented Swiss-French letters.

Any issues? Would that work for you?
avatar
Simoncu
Posts : 13
Join date : 2019-05-15

cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG Empty Re: cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG

on Mon Apr 06, 2020 9:54 am
Of course that would work for me, but I don't want to go back and forth between 2 keyboards, because I'll forget I switched one time, and I type y instead of z and that's not a solution for me. I want to use my Swiss french keyboard all the time, your solution is a "band-aid on a wooden leg" as we say in French ;-)it is a workaround, but that's not what I want. I want to type @ and have @ coming in the address, not the junk folder opening, that's it....
Admin
Admin
Admin
Posts : 182
Join date : 2018-06-02
http://www.drivehq.com/web/brana/pandora.htm

cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG Empty Re: cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG

on Tue Apr 07, 2020 8:43 am
Of course it's a crutch/band aid, but it's a clean work-around until something better comes along, to quote Weird Al.
There will be (at least) one dedicated update related to international keyboard layouts, accessibility, local hot-keys.
avatar
croos
Posts : 14
Join date : 2020-07-20

cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG Empty Re: cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG

on Thu Jul 23, 2020 3:36 pm
I posted about the same problem a few days ago. Sorry, I didn't realize there already was a thread going.
https://pandoramail.forumotion.net/t121-newbie-questions#438

If I understand what I read in this thread right, there is no solution ATM but there is one coming. Can you give us a hint about when that is likely to happen? If there's just a short delay I can copy-paste for a while, but if it's many months or years away, not so fun.
Admin
Admin
Admin
Posts : 182
Join date : 2018-06-02
http://www.drivehq.com/web/brana/pandora.htm

cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG Empty Re: cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG

on Fri Jul 24, 2020 4:44 am
Correct, you'll be able to assign local keyboard-shortcuts for all commands/menus. It'll be under Settings/Toolbar and Commands.

The important prerequisite for that is coming up next, that is - fully owner drawn menus. [Starting with version 3.7 we'll be able to chose Windows theme file (for Pandora only).] So hot-keys will be there in version 3.9 or 4.x. It's months, not years thought.
avatar
croos
Posts : 14
Join date : 2020-07-20

cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG Empty Re: cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG

on Fri Jul 24, 2020 11:08 am
Thank you. Is it like 2-3 months or more like 11-12 though? Smile

If it's likely to be less than half a year, I think I'm in. Webmail isn't fun either. The problem is I'm reluctant to start to download from all accounts and move mailboxes and so on if I'm not sure Pandora is a keeper.
avatar
croos
Posts : 14
Join date : 2020-07-20

cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG Empty Re: cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG

on Fri Jul 24, 2020 9:57 pm
I caved and payed for the license. I trust your word the keyboard issue will be fixed. But PLEASE, PLEASE make it sooner rather than later. It's really annoying. But apart from that I'm very pleased with what I've seen so far. You've done a great job with Pandora. Like a Star @ heaven Like a Star @ heaven Like a Star @ heaven Like a Star @ heaven Like a Star @ heaven
Admin
Admin
Admin
Posts : 182
Join date : 2018-06-02
http://www.drivehq.com/web/brana/pandora.htm

cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG Empty Re: cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG

on Mon Jul 27, 2020 11:36 pm
Good, thank you.
We are looking at 4-6 months period, feel free send us a feedback via Help/Send Feedback/Report a Bug menu, anything specific to Swiss-French layout. If there is anything fundamentally different from Swiss-Deutsch layout (which will be used for testing) let us know.
avatar
croos
Posts : 14
Join date : 2020-07-20

cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG Empty Re: cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG

on Wed Jul 29, 2020 3:04 pm
You mean if Swedish layout differs from Swiss-French? It must. I posted an image above of Swedish layout above. CTRL + whatever should be safe if it could be stopped from being triggered by CTRL + ALT and ALT GR.
Sponsored content

cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG Empty Re: cannot use keyboard to do " @ " (with my swiss-french keyboard is ALTG

Back to top
Permissions in this forum:
You cannot reply to topics in this forum